0
Declined

Why is my robotic arm model falling apart?

叽叽叽 4 weeks ago updated by Support 3 weeks ago 5

I used the cad import tool to import my manipulator model, but after running my manipulator model fell apart, how can I solve this situation?

Image 764

Answer

Answer
Completed

I think the pivot points of your Axis1... Gameobjects are not where they should.

If needed you need to set empty gameobjects with the correct pivot points - like in the robot data sheet. After this you can put your meshes in. Drives are always rotating around pivot points. Please turn on the pivot point visualization in editor mode.

Under review

I am sorry, but I do need more information. How did you build up the robot arm. How are the axis linked. I would need screenshots of hierarchy and properties on the axis.

Hello, thank you for your reply, can I show you my step file by some means, I imported this file through cad importer, the coordinate information of his axis should be very similar to the abb robot in the demo, so I dragged all the parts in my robotic arm to the AXIS in the abb robot. After the dragging was completed, the animator that was originally in the demo and mounted on the abb robot ran very normally after running. But after I import robot ik and robot path and run it again, the robot shrinks into a ball. I tried to build it several times, and finally this happens. I am very distressed, it wastes a lot of my time, the picture below is The situation of my axis, if possible I would like to send you my robot step file, then you can try it。

Image 766

Image 765

Answer
Completed

I think the pivot points of your Axis1... Gameobjects are not where they should.

If needed you need to set empty gameobjects with the correct pivot points - like in the robot data sheet. After this you can put your meshes in. Drives are always rotating around pivot points. Please turn on the pivot point visualization in editor mode.

Image 767

I think my axis settings should be correct, that's why the animator can be run, now I open the huddled robot here and find that the model has completely disappeared, I'm confused, if you can, allow me to you send the step file