0
Under review

OPCUA runs in player/editor but indicates "specified license not valid" in build (G4APro licensed)

Joel 10 months ago in realvirtual.io Starter and Professional updated by Support 10 months ago 7

In my application I use (this time) only the OPC UA connectivity of my G4A prof licensed installation. In player and editor all is working well but when I run a build the log shows "The specified license is not valid." and therefore makes no connection.

Answer

-1
Answer

Hi, I am in vacation until this Thursday. I think it will be best to look first into your project and to check. You can send us your NDA to info@game4automation.com and I can sign on Thursday morning.

Best regards

Thomas

+1

@Support please help, my application is to go live with my client soon...

-1
Under review

Hi, you are deploying to which destination platform. Which version of G4AProf are you using. Can you share your project so that we are able to check?

-1

Hi,

I am using Unity 2020.3.7f1 with G4A 2020.13.0, this is running perfect and fast from Player without any issues about licenses etc. When running the build exec it indicates there is a license issue, with OPC client and therefore will not connect.

I also upgraded my project to Unity 2020.3.29f1 with G4A 2020.15.0, however this runs and resolves the issue with the license then only 50 tags get connected and all is really slow, this is the same code however so I fail to understand why.

The project I can send if needed however there needs to be some non-disclosure agreement signed in advance to ensure our and my clients IP is protected. Can you issue a NDA to me or alternatively send me an email address that I can send you our standard issue?

Alternatively having a quick call and remote session may also help, let me know what is best for you. Really appreciate your quick support in resolving the issue.

Thanks!

Joel.

-1

Building to Win x86_64, Mono .NET Standard 2.0

+1

one thing to add actually, when starting the OPC client with G4A 2020.13.0, all tags are written to 0/false on start up. Even the tags that are indicated to be read ony and/or subscription.

+1

also build to x86, same result

-1
Answer

Hi, I am in vacation until this Thursday. I think it will be best to look first into your project and to check. You can send us your NDA to info@game4automation.com and I can sign on Thursday morning.

Best regards

Thomas