0
Fixed

Unity 2020.3.39f1 UWP deployment does not complete successfully

SzeltnerD 2 months ago in realvirtual.io Starter and Professional updated by Support 1 month ago 3

Hello,
I am working with HoloLens and Unity 2020.3.39f1. I imported "game4automation-Professional-2020.15" and when I build my app as an UWP I get an error. I fixed the error by replacing both files "game4automation\private\Tools\ZIP\I18N.dll" & " game4automation\private\Tools\ZIP\I18N.West.dll" with a version targeting ".Net 4.x".
After this fix, I can successfully build the Visual Studio Solution. When I deploy the app to HoloLens, the deployment always stops at the same step.

Image 707


In Unity 2019.4.40f1 with "game4automation-Professional-2019.13" I had to replace the same files. After that it worked and I could run the app on the HoloLens.

GOOD, I'M SATISFIED
Satisfaction mark by SzeltnerD 1 month ago
Under review

Hi,

we will need to check if we can generally replaye the DLLs. Is there more information why it stops?

Is ist stopping on all UWP builds or only if you build for Hololens. For Hololens we can't check because we don't have a hololens any more.  In General we realized, when we tested with Hololens, that it is complicated to complile to Hololens. My advice would be to throw anything out of the project which could make problems. You should delete in the project:

- Cadlink 

- All Interface folders that you don't need (most of them are not able to communicate on Hololens)


Best regards

Thomas

Hi,

unfortunately there is no information about why the process stops. It stops at the end of the build process. So even before it is loaded on the HoloLens. I don't think the problem is HoloLens specific. Maybe it is due to the architecture (ARM64) of the UWP.

I deleted one component at a time and after deleting the "game4automation\private\Interfaces\OPCUA4Unity" folder, the build process worked. The problem seems to be in the OPCUA interface.

Best regards

Fixed

Ah ok sorry - this is a know issue - we already described it here:

https://realvirtual.io/documentation/current/platforms.html