0
Fixed

OPCUA plc input script don´t write to server opcua and plc

Edu 1 month ago in OPCUA4Unity updated by Support 3 weeks ago 13

Hello

I have managed to connect opcua4unity with the kepware server.

opcua4unity <-> kepserver <-> cp1l(omron) and opcwatch.

opcwatch connects perfectly with kepserver, reads and writes without problems.

opcua4unity connect ok, import nodes ok and read ok, but don't write values to server and plc.

attached photos.


Image 753

Image 754

I have also tried write value=on and subscribe value=off, but it doesn't work either.

Thank you.

Answer

Answer

The issue is solved and will be released today in realvirtual.io Professional 2021.10.

Under review

What I am wondering about is, that you are subscribing for the value. You should only subscribe for Outputs. Please try in changing this and maybe if it still does not works please do a test setup where you try only one Input. 

Maybe one more reason is, that you are not able to write to physical available PLC inputs. If the (real) input (where the wire is connected to) is low - you might not be able to put it to a high. Maybe you need to write into a PLC area where no "real" inputs are defined. But this is just a guess - we don't know Omron.

Best regards

Thomas

Can you turn on DebugMode - is there something written in the ConsoleLog?

the area "D" where  try to write is a memory area and not physical channel.

I also tried without subscribing and it doesn't work either.

I have tried to write booleans in the memories of brands of omron plc and it does not work either.

but all this can be written from opcwatch.

Best regards
Edu

Hi, currently I don't know where the problem is. On our side the test models with writing signals to an OPCUA server are working. Maybe there is something special with your OPCUA server but I have no clue where your problem is. We can't test it here on our side because we have no Omron PLC. And as I can see there is also no error message in the console log. Do you see any chance that we can get a connection to your OPCUA server. Maybe via a temporary VPN like ZeroTier?

Maybe also try to just have one node in a model and to just write that node.

in the photo I sent from unity the console notice says that I have to disable subscribe value.

I've tried it but it doesn't work either, although the warning no longer appears.

Image 755

in this last photo debug mode is on, in OPCUA_Interface

I have done tests with the kepserver simulator

without the omron plc, only with one node and with the same result.


between clients such as opcwatch or uaexpert being both connected if they can write and see the value updated on the other.

It seems fine to me to make a connection with zero tier or anydesk.

Thank you.

Image 759

Image 762

Hi, I am today (european time) one day off but will work today evening and Saturday evening. Can you setup a ZeroTier network and provide me the information about the ip adress of your OPC UA server? Or we agree on a fixed time on Monday when I will do the tests?

Hello good day.

I was doing tests yesterday with zero tier (1 computer with kepserver the other as a client), I managed to connect two PCs through zero tier but the client cannot connect to kepserver.

I think it's because of the DCOM settings.

I am going to try to configure the DCOMs and I will do tests, when I get an external connection to kepserver with zero tier I will let you know.

I will try to have everything by Monday and be able to tell you an hour.

Thanks a lot

okay

at 18:00 is perfect

I am from Spain and share the same schedule as Germany.

I do not have Teams but I will install it now and I will be connected at 18:00 pm

a greeting

Answer

The issue is solved and will be released today in realvirtual.io Professional 2021.10.