+1
Fixed

No Mutex PLCSim Advanced Interface proble

Pablo 9 months ago in realvirtual.io Starter and Professional updated by Support 2 months ago 18

Hello,

we are using the PLCSim Advanced Interface.

We can Import the PLCSignals without any Troubles:

Image 519

The first time that we start the simulation in Unity everything is working fine (COM OK).

But after we stop the unity editor and try to start again, we get “No Mutex”... so no communication is established between the plc and Unity.

We found out that creating a new PLC Instance and re-importing the signals “fix the error”... but just for the first run. Then we have to repeat the process of creating a new PLC again and again...

Could be some background process blocking the communication? Thank you in advance.

Answer

+1
Answer
Fixed

Current working coupler.exe is available in the download area:

https://realvirtual.io/download/PLCSimAdvancedCoupler.exe

Planned

Hi Pablo,

thanks - I will send you a beta today or tomorrow. Maybe you can check with the beta if the problem still occurs. 

Best regards

Thomas

Hello Thomas,

We are glad to hear that. We are looking forward to the beta so that we can test this issue thoroughly and see if it has been resolved.

We'll be in touch

Kind regards

Sadly im experiencing the exakt same problem.

It is not necessary tied to "first time it works and never again" - more a type of "i try it 20 times and then it suddenly works for one time again".

It is anoying as hell and interrupts the workflow massivly :-)

What i noticed:

The Coupler tries to restart the PLC in PLCSimAdvanced. If this fails(yellow light in PLCSA) then you get the NoMutex in the Couplers log. But when the coupler can start the PLC (green box in PLCSA) everything is working fine. 

When starting up the PLC manually in PLCSA it boots up without any problem, but ofcourse with the mutex in the console, it doesnt work afterwards.

Maybe the coupler doesnt start or verify the start of the PLC correctly?

We had an issue with some timing, which I thought that it is solved. Which version are you using? I am today not in the office  but I will take care on Monday.

Fixed

Hi Andre,

we just uploaded a new PLCSimAdvancedCoupler.exe to our download section:

https://realvirtual.io/download/PLCSimAdvancedCoupler.exe

Please try to use this one, this should fix the issue.

Best regards

Thomas

The error is still present on my end. 

I replaced the Coupler with the one you provided.

Here is a video of the Error happening:

NoMutex

Under review

Please turn debug mode in the PLCSIMAdvanced interface on and send me the console log.

Editor.txt


This is the Log file with Debug Mode enabled on the PLCSimAdvancedInterface GameObject and one startup of the Editor which resulted in the "No Mutex" error.

I have doupts, that you really used the .exe which I have send.

Please check the project directory and delete all the .exe (one is under StreamingAssets).

If you have no success I will need to check with you on your computer tomorrow.

I deleted and replaced the .exe under 

"Assets\game4automation\private\Interfaces\PLCSimAdvanced\Ressources" 

so indeed you where correct that the exe was the false one.

I replaced your provided exe with the one under StreamingAssets but it seems that nothing changed. The NoMutex Error still appears after a succesfull startup.

The Editor log seems to be the same as before.

NewEditor.txt

Additional Info:

EVERY time i restart Unity its working fine, i NEVER got the "No Mutex" at the first startup of the playmode in Unity.

When retrying the second and third time exiting and entering the Playmode i encounter the No Mutex and it doesnt go away itsself(sometimes it does) but EVERY time i restart Unity the first time it just works as it should.

But restarting Unity everytime entering the playmode is just ridiculous

Can we meet via teams and check the issue. Tomorrow will be best for me. If needed I will add aditional debugs in the exe in the meeting so that we see what is happening. Can you send me also the log of the .exe file for checking.

The problem is, that this is somehow a timing issue. We can't reproduce it on our computers and I thought that it is fixed because it was fixed in a Teams meeting with another customer. So only solution is that we closely work together, I will need to check your logs on your computer and maybe add additional debug infos.

A meeting today afternoon between 14:00 and 16:00 is also possible

I just sended you a teams invite for a meeting at 15:00 today afternoon.

+1
Answer
Fixed

Current working coupler.exe is available in the download area:

https://realvirtual.io/download/PLCSimAdvancedCoupler.exe

Hello,I used PLCSIM Adv last year,and it also shows No Mutex sometimes,so I have to tell custom to restart software。Now I use PLCSIM and NetToPlcsim,the interface is S7,it always connect to TIA Portal。

I find PLCSIM Adv only support 1500 CPU,PLCSIM support 300 、400 、1200 、1500CPU。PLCSIM Adv must have the same variable name in Unity and TIA Potal,S7 interface could use different variable name just make sure variable Address such as Q0.0。PLCSIM Adv must install in Win10 Professional to use,PLCSIM dose not。

I hope it helps。